check 3d gpu
바로가기
왼쪽 메뉴로 이동
본문으로 이동

PHP GD 라이브러리 서비스 거부 취약점 발견돼...패치 필수

2018년 02월 09일(금)
공유하기

구글+구글+ 카카오톡카카오톡 카스카스 라인라인 밴드밴드 URL복사URL복사

URL 복사

아래의 URL을 길게 누르면 복사하실수 있습니다.

coding-1841550_640.jpg
최근 PHP GD 라이브러리에서 서비스거부 취약점(CVE-2018-5711)이 발견되었다. 해당 취약점으로 PHP의 서버 CPU 사용률을 순간적으로 100%로 만들어 버릴 수 있다.

GD 라이브러리의 gf_gif-in.c에는 정수서명오류가 존재해, 특별히 조작된 GIF 파일을 이용한다면 PHP 함수의 imagecreatefromgif 또는 imagecreatefromstring가 불러들여질 때 무한루프를 발생시킬 수 있다.

취약점은 ext/gd/libgd/gd_gif_in.c 코드에 존재한다.

GetDataBlock이 -1을 반환할 때, 두번째 코드 중 카운트 값이 이 값을 할당할 수 없기 때문에 버그가 발생하는 것이다.

PHP GD 라이브러리 이전 버전 사용자는 최신 버전으로 업데이트해야 안전할 수 있다.

★정보보안 대표 미디어 데일리시큐!★

길민권 기자 mkgil@dailysecu.com

전체선택후 복사하여 주세요. 닫기